Trouble Installing Thematic Child Theme

Home Forums Using Thematic Child Themes Build Your Own Custom Child Themes Trouble Installing Thematic Child Theme

This topic is: resolved

This topic contains 5 replies, has 3 voices, and was last updated by  Gene (emhr) 1 year, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2800

    emmaconstance
    Participant

    I am new to WordPress, but I have searched up and down for the solution for my problem and no other issue seems to be similar to mine.

    I first attempted to write my own child theme and ran into this same problem so I did the following, but the same thing keeps happening, so I don't know what I am doing wrong.

    I copied the "thematicsamplechildtheme" folder info (style.css, readme.txt and functions.php) into my new child theme's folder in the root level of wp-content/themes just as the readme instructed.

    However, when I go to install the theme on my WordPress page it says that the theme is installed by incomplete because the stylesheet is missing.

    This is the stylesheet provided with my edits. Again I am completely new to this so it is very possible that I just don't see something:

    /*
    Theme Name: EC's Thematic
    Theme URI: http://www.emmaconstance.com
    Description: A Child Theme Based on Thematic
    Author: Emma Constance
    Author URI: http://www.emmaconstance.com
    Template: thematic
    Version: 1.0
    Tags: white, three-columns, two-columns, fixed-width, theme-options, left-sidebar, right-sidebar, threaded-comments, sticky-post, microformats
    License: GNU General Public License v2.0
    License URI: http://www.gnu.org/licenses/gpl-2.0.html

    .
    The Thematic Theme is copyright Ian Stewart http://themeshaper.com/
    This work, like WordPress, is released under GNU General Public License, version 2 (GPL).
    .

    */

    /* Reset browser defaults */
    @import url('../thematic/library/styles/reset.css');

    /* Apply basic typography styles */
    @import url('../thematic/library/styles/typography.css');

    /* Apply a basic layout */
    @import url('../thematic/library/layouts/2c-r-fixed.css');

    /* Apply basic image styles */
    @import url('../thematic/library/styles/images.css');

    /* Apply default theme styles and colors */
    /* It's better to actually copy over default.css into this file (or link to a copy in your child theme) if you're going to do anything outrageous */
    @import url('../thematic/library/styles/default.css');

    /* Prepare theme for plugins */
    @import url('../thematic/library/styles/plugins.css');

    /* Overriding Thematic's styles for congruity with WP-Admin > Appearance > Header default header text color settings */
    #blog-description { color: #000 }

    I originally posted this on the WordPress forums, but it was suggested I come here for help.

    Thank you for your help!

    Emma

    #2801

    Scott Nix
    Moderator

    Well, I don't see anything incorrect with what you posted.

    Have you tried to just use the /thematicsamplechildtheme/ and testing to see if it works without any changes made at all? Like don't modify a single thing.

    There really isn't much to mess up here, has to be something really tiny. :/

    #2809

    emmaconstance
    Participant

    Thank you for your reply.

    I think so, too. I did just try using the /thematicsamplechildtheme/ without any changes and the same thing happened. Could it be that I am putting the file in the wrong place or naming the file wrong? The file is located at /emmaconstance.com/wp-content/themes/EC's Thematic. The file is called EC's Thematic.css.

    Thank you for any help. This whole issue has been so frustrating! I just want to get my site off the ground!

    #2810

    Gene (emhr)
    Moderator

    Your problem is caused by a file naming issue.

    Here're my suggestions:

    • Use all lower case.
    • Try using dashes where you would have used spaces.
    • Use only alpha numeric characters. ABC 123 etc. So dont' use special characters such as apostrophes

    So try this:

    1. Rename your child theme directory emmas-childtheme
    2. Rename your child theme's stylesheet style.css. This is a required file name... other wise you'll keep running  into the same error.
    3. Activate your child theme.

    Read this for more detailed info: http://codex.wordpress.org/Child_Themes

    Hopefully that'll resolve your issue. If so please set the status of the topic as "Resolved" in both this thread and the other one at WordPress.org

    #2813

    emmaconstance
    Participant

    Gene, thank you so much! That fixed it!

    #2814

    Gene (emhr)
    Moderator

    :)

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Trouble Installing Thematic Child Theme’ is closed to new replies.